QQ登录

只需一步,快速开始

登录 | 立即注册 | 找回密码

主题

帖子

荣誉

鱼友Ⅱ

Rank: 3

积分
212
查看: 502|回复: 3

yum问题

[复制链接]
最佳答案
0 
累计签到:87 天
连续签到:1 天
546397641 发表于 2018-1-22 23:29:00 5023 | 显示全部楼层 |阅读模式

马上注册加入鱼C,享用更多服务吧^_^

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
本帖最后由 546397641 于 2018-1-23 15:14 编辑

自带Python是2.6,升级到了python3.6
然后使用yum工具报错
33.jpg
按照网上教程,将yum文件中的python 改为了python2.6,
44.jpg
但是报错
-bash: /usr/bin/yum: /usr/bin/python: bad interpreter: No such file or directory
请问怎么回事?

bin/ 文件中的python文件,感觉颜色(红色)好像不对(查了一下,红色是压缩文件)
55.jpg
楼层
跳转到指定楼层
最佳答案
0 

尚未签到

nforev 发表于 2018-1-25 13:41:49 | 显示全部楼层
你可以试试改成 python2 而不是python2.6.
最佳答案
0 
累计签到:87 天
连续签到:1 天
546397641  楼主| 发表于 2018-1-27 11:25:35 | 显示全部楼层
nforev 发表于 2018-1-25 13:41
你可以试试改成 python2 而不是python2.6.

试了,python2也不行
最佳答案
10 
累计签到:174 天
连续签到:2 天
AndyZhou 发表于 2018-1-28 13:25:37 | 显示全部楼层
你弄错了!!!每个编写好的linux都是自带python2和python3的,就算没有python3也是自建一个,但绝不是从python2升级,因为现在很多linux都有一些部分需要python2.............然后你给升级了......你先检测你系统里有没有python2,如果没有就装一个吧......
然后python3要搁到path里去,要么终端就检测不到......然后把python3设为默认https://www.cnblogs.com/dplearning/p/5681866.html

发表回复

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

小甲鱼强烈推荐 上一条 /1 下一条

    移动客户端下载(未启用)
    微信公众号

小黑屋|手机版|Archiver|鱼C工作室 ( 粤ICP备11014136号

Copyright 2018 鱼C论坛 版权所有 All Rights Reserved.

Powered by Discuz! X3.1 Copyright
© 2001-2018 Comsenz Inc.    All Rights Reserved.

小黑屋|手机版|Archiver|鱼C工作室 ( 粤公网安备 44051102000370号 | 粤ICP备11014136号

GMT+8, 2018-5-25 15:18

快速回复 返回顶部 返回列表